Forum Home Forum Home > Expression Web > Expression web 3 and 4
  New Posts New Posts RSS Feed - changes made to my code by EW
  FAQ FAQ  Forum Search   Register Register  Login Login


Welcome to expression web help - thank you for joining us.

changes made to my code by EW

 Post Reply Post Reply
Author
Message
kabbinboy View Drop Down
Just starting out
Just starting out
Avatar

Joined: 04 Nov 2017
Location: Illinois, U.S.
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote kabbinboy Quote  Post ReplyReply Direct Link To This Post Topic: changes made to my code by EW
    Posted: 04 Nov 2017 at 5:04pm
Can't seem to find the right place to ask this Q; hope someone can help...

My partner and I are working on re-doing a website to make it responsive.  We are working on the same site – thought not at the same time – on two different machines, both obviously loaded with the same version of Expression Web 4.  When the following code is added to her machine, it works fine upon publishing and the product images appear.

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

 When I open the same site and page to work on other code and text, the file previously mentioned above suddenly appears as follows:

<script async src="file:///pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

The product description appears but not the images.  If she publishes from here machine, everything works fine.  If I have worked on the same files – even though I have not touched the ad files, the revert to the version that has the “file:/” added to the front end of the code.

Any suggestions as to how to fix this problem?

Back to Top
Sponsored Links


Back to Top
jimd View Drop Down
Admin Group
Admin Group


Joined: 16 Oct 2006
Location: United Kingdom
Status: Offline
Points: 6236
Post Options Post Options   Thanks (0) Thanks(0)   Quote jimd Quote  Post ReplyReply Direct Link To This Post Posted: 09 Nov 2017 at 8:38pm

Hi sorry to have missed this post.

I think the issue is synchronisation your partners machine will have the uploaded version - whilst yours will not because you didn't have the files or script to upload.

The solution is for you to download from the server the most recent upload! Does that make sense?

The problem could be ongoing - so when either party uploads something, the other party needs to download it to sync

Let me know if you need more help.

Thanks

JIM


Back to Top
kabbinboy View Drop Down
Just starting out
Just starting out
Avatar

Joined: 04 Nov 2017
Location: Illinois, U.S.
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote kabbinboy Quote  Post ReplyReply Direct Link To This Post Posted: 09 Nov 2017 at 10:20pm
Hi Jim -
Not a problem -- thanks for getting back.  Your answer does make sense, but I don't think synchronization is the problem.  We both have identical software and the site resides solely on my partner's machine, which acts as the server.  We never open the site while the other is working on it.  If she works on the site and saves it, all of the "src="// http://ws-na.amazon-adsystem.com - ws-na.amazon...etc." code used on the site is saved correctly as she has typed/received it from Google.  If I so much as simply open the same uploaded/saved file, all of the code now appears with "src=file../// http://ws-na.amazon-adsystem.com - ws-na.amazon..." where the bolded stuff is what has been added by my machine.  She then has to go back and re-code everything back to what it previosly was.

I have had similar things happen before, with Expression Web arbitrarily adding code to hyperlinks I have created; like it's trying to identify my machine as different.  I am stumped.  Any other ideas would be appreciated.  And the bummer of it is, we are re-designing a very large site, but it's going to take far longer to finish it if we can only work on a single machine.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.047 seconds.